callbackAddField value not send to form when field is set to combobox

hello @johnny
i use new version 3.0.9 with php 8.1
value of form not send when submit button is press
this is the picture

this is my controller

and this is my view to generate combobox

Hello @nasrul ,

This is probably an issue with a JavaScript plugin that you use? Can you share the callbackAddField function that you use?


thanks for your replay @johnny
i change my combobox with pure html
but the value still not send

this is my callbackAddFields

this is my complete controller @johnny
public function floor()
$test = $this->action_get;
$test2 = $this->action_post;

$crud = $this->grocery->_getGroceryCrudEnterprise();
$crud->defaultOrdering('id', 'desc');
$crud->setSubject('Floor', 'Floor');
$crud->callbackAddForm(function ($data) {
    $data['created_by'] = Auth::user()->id;
    return $data;
$crud->callbackAddField('barang_id', function ($fieldType, $fieldName) {
    return "<select name='$fieldName' class='form-control'><option value='1'>satu</option><option value='2'>Dua</option>";
    // return view('plugins.chosen_barang_floor')->render();
// $crud->callbackAddField('barang_id', function ($fieldType, $fieldName) {
//     return view('plugins.chosen_barang_floor')->render();
// });
$crud->callbackAddField('satuan_id', function ($fieldType, $fieldName) {
    return view('plugins.chosen_satuan')->render();
$crud->callbackEditField('barang_id', function ($fieldValue, $primaryKeyValue, $rowData) {
    return view('plugins.chosen_barang_floor',['barang_id'=>$fieldValue])->render();
$crud->callbackEditField('satuan_id', function ($fieldValue, $primaryKeyValue, $rowData) {
    $getBarangId = DB::table('mst_floor')->where('id',$primaryKeyValue)->first();
    return view('plugins.chosen_satuan',['satuan_id'=>$fieldValue,'barang_id'=>$getBarangId->barang_id])->render();
$crud->callbackAfterInsert(function ($stateParameters) {
    $redirectResponse = new \GroceryCrud\Core\Redirect\RedirectResponse();
    return $redirectResponse->setUrl('/admin/floordetail/' . $stateParameters->insertId);
$crud->setActionButton('Detail', 'fa fa-info', function ($row) {
    return '/admin/floordetail/' . $row->id;
}, false);

$output = $crud->render();
$menu = array('menuMaster' => 'here show','menuFloor'=>'active');
$customHrefAddButton = view('plugins.chosen')->render().view('plugins.chosen_grocery_crud')->render();
$extra = array('menu'=>$menu,'jsExtra'=>$customHrefAddButton);
return $this->grocery->_showOutput($output,null,$extra);


Hello @nasrul ,

This was a Grocery CRUD bug and I’ve fixed the issue for the latest version. Since this was a very small frontend change, I’ve redeployed version 3.0.9 today so in case you have downloaded the version earlier please download it again and let me know if this is working for you.


Thank you @johnny
I’ve tried to update to the latest version but it still doesn’t work
I tried to update by

  1. following the instructions of the installation wizard but it hasn’t worked yet
  2. via composer update but the same is also not successful
    maybe there are instructions for how to update the latest version


Hello @nasrul ,

I think the only thing extra you need is to do a hard refresh. More specifically:

  • Press right click “Inspect” and then go to the top refresh button press it and then click “Empty cache and hard reload”:
    Screenshot 2023-07-10 at 7.45.30 AM

If this is still not working then it is probably a cache issue with composer. Try to do something like this:

composer install --no-cache

And let me know if that worked for you.


If the above still doesn’t work, then please try to remove the package and then install it again like this:

composer remove "grocery-crud/enterprise"
composer require "grocery-crud/enterprise:3.*.*@dev" --no-cache

And of course don’t forget to also copy the assets files since the change is on the JavaScript files.


thanks so much @johnny its running well now

1 Like

I am very glad to hear that :hugs: Thanks for letting me know