"Either the user doesn't have access to this row, either the row doesn't exist"

Can a future version of GC have the hardcoded exception messages (e.g. “Either the user doesn’t have access to this row, either the row doesn’t exist.” in EditFormState.php) moved to the language files?

Until then, is there a way to override these messages without editing GC source files?