post by kapilchugh on Feb 17, 2025

Hi @johnny - I am getting following error while running this command. It seems it is trying to upgrade to 3.1.13 which is not yet released officially

composer update --prefer-dist

  • Upgrading grocery-crud/enterprise (3.1.12 => 3.1.13) .
    “message”: “Undefined constant Kint\Renderer\AbstractRenderer::SORT_FULL”,

post by johnny on Feb 17, 2025

Hello @kapilchugh ,

I believe that this is not a Grocery CRUD issue but a Codeigniter 4 issue because you are also upgrading Codeigniter as well. I have an answered question in stackoverflow that I believe that it will help you: https://stackoverflow.com/questions/78391795/error-after-updating-codeigniter-4-system-bootstrap-php-is-no-longer-used/78742970#78742970

Let me know if that solved your issue.

Regards
Johnny

post by kapilchugh on Feb 17, 2025

No, it didn’t get resolved. Actually there is no difference in spark and public/index.php files after copy. I am also using PHP 8.2. There might be something else.

post by johnny on Feb 18, 2025

Hello @kapilchugh from a quick research it seems that this is a Codeigniter 4 upgrade issue but I’ve spotted the wrong direction. Please check this post here: https://forum.codeigniter.com/showthread.php?tid=86106 for more.

In short you will need to go to: app/Config/Kint.php and replace Kint\Renderer\Renderer with Kint\Renderer\AbstractRenderer and replace Renderer::SORT_FULL with AbstractRenderer::SORT_FULL

If after this you’ve faced another issue check Codeigniter 4 upgrade notes that may help you: Upgrading from 4.2.12 to 4.3.0 — CodeIgniter 4.7.5 documentation

Regards
Johnny

3 months later

post by kapilchugh on May 7, 2025

1 / 5
Feb 2025